Contenido mit MySQL 5.5 installieren

Ein Kunde berichtete uns heute, dass das kostenlose CMS Contentido seit unserer Umstellung auf MySQL 5.5 nicht mehr installierbar sei. Ursache dafür ist, dass MySQL 5.5 die offiziellen Standards wesentlich strikter einhält als frühere Versionen. Zur Lösung des Problems mit Contentido müssen zwei Dateien innerhalb des Setups angepasst werden:

/setup/lib/functions.mysql.php:
Zeile 175: Ersetzen Sie bitte „TYPE = MYISAM“ durch „ENGINE = MYISAM“ (ohne Anführungsstriche)

/setup/data/tables.txt
Ersetzen Sie alle Vorkommen von „timestamp(14)“ durch „timestamp“ (ohne Anführungsstriche). In unserer getesteten Version gab es 4 Vorkommen mit diesem Fehler.

Nach der Korrektur dieser beiden Dateien sollte der Installationsprozess ohne Probleme durchlaufen.

Leave a Reply